Archiv

Oktober 2012
M D M D F S S
« Sep   Nov »
1234567
891011121314
15161718192021
22232425262728
293031  
Download PDF

Wartung: 23.10. neues PHP5.4.7 auf Studentenwebserver – Achtung neue Sicherheitseinstellungen!

Die auf dem Studenten-Webserver zur Verfügung stehende PHP-Version 5.2.17 wird am Dienstag, den 23.10.2012 im Rahmen eines Wartungsfensters auf die aktuelle Version 5.4.7 angehoben. Nach ersten Recherchen wird das Upgrade eine Reihe von Entwicklern betreffen.

Es ist zu befürchten, dass ein nicht unerheblicher Teil der Anwendungen nicht mehr laufen wird, da veränderte Sicherheitseinstellungen greifen. Vergl. http://www.heise.de/developer/meldung/PHP-5-4-offiziell-freigegeben-1446789.html – dort heisst es: „So werden Entwickler künftig auf register_globals, Magic Quotes oder den Safe Mode verzichten müssen. Die Änderungen brechen voraussichtlich die Kompatibilität zu (sehr) alten PHP-Applikationen …“

Siehe auch http://de.php.net/manual/en/security.globals.php

Bitte aktualisieren Sie Ihre Programme (sofern selbst erstellt) bzw. aktuelisieren Sie installierte Software auf einen aktuellen Stand.

Kommentieren

FernUni-Logo FernUniversität in Hagen, Zentrum für Medien und IT (ZMI), 58084 Hagen, Tel.: +49 2331 987-2809, Fax: +49 2331 987-2720